rules 995 B

1234567891011121314151617181920212223242526272829303132
  1. #!/usr/bin/make -f
  2. # See debhelper(7) (uncomment to enable)
  3. # output every command that modifies files on the build system.
  4. #DH_VERBOSE = 1
  5. # see EXAMPLES in dpkg-buildflags(1) and read /usr/share/dpkg/*
  6. DPKG_EXPORT_BUILDFLAGS = 1
  7. include /usr/share/dpkg/default.mk
  8. # see FEATURE AREAS in dpkg-buildflags(1)
  9. #export DEB_BUILD_MAINT_OPTIONS = hardening=+all
  10. # see ENVIRONMENT in dpkg-buildflags(1)
  11. # package maintainers to append CFLAGS
  12. #export DEB_CFLAGS_MAINT_APPEND = -Wall -pedantic
  13. # package maintainers to append LDFLAGS
  14. #export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
  15. ifneq ($(DEB_HOST_GNU_TYPE),$(DEB_BUILD_GNU_TYPE))
  16. export CMAKE_TOOLCHAIN_FILE=/etc/dpkg-cross/cmake/CMakeCross.txt
  17. endif
  18. # main packaging script based on dh7 syntax
  19. %:
  20. dh $@ --parallel --buildsystem=cmake
  21. # debmake generated override targets
  22. # This is example for Cmake (See http://bugs.debian.org/641051 )
  23. override_dh_auto_configure:
  24. dh_auto_configure -- \
  25. -DCMAKE_BUILD_TYPE=Release \
  26. -DARM_MIX_32_64=ON