Prechádzať zdrojové kódy

luci-app-olsrd2: upgrade uci-defaults for ucitrack handling to use json

Conversion of the 'uci-defaults' script for ucitrack handling to the new
json processing.

Signed-off-by: Florian Eckert <fe@dev.tdt.de>
Florian Eckert 1 rok pred
rodič
commit
d4e9f920ea

+ 3 - 3
luci-app-olsrd2/Makefile

@@ -3,7 +3,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=luci-app-olsrd2
 PKG_VERSION:=0.2.6
-PKG_RELEASE:=15
+PKG_RELEASE:=16
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 
 include $(INCLUDE_DIR)/package.mk
@@ -42,8 +42,8 @@ define Package/$(PKG_NAME)/install
 	$(INSTALL_DATA) ./htdocs/luci-static/resources/view/olsrd2/* $(1)/www/luci-static/resources/view/olsrd2
 	$(INSTALL_DIR) $(1)/etc/config
 	$(INSTALL_DATA) ./root/etc/config/* $(1)/etc/config
-	$(INSTALL_DIR) $(1)/etc/uci-defaults
-	$(INSTALL_DATA) ./root/etc/uci-defaults/* $(1)/etc/uci-defaults
+	$(INSTALL_DIR) $(1)/usr/share/ucitrack
+	$(INSTALL_DATA) ./root/usr/share/ucitrack/luci-app-olsrd2.json $(1)/usr/share/ucitrack
 	$(INSTALL_DIR) $(1)/usr/libexec/rpcd
 	$(INSTALL_BIN) ./root/usr/libexec/rpcd/status.olsrd2 $(1)/usr/libexec/rpcd/status.olsrd2
 	$(INSTALL_DIR) $(1)/usr/share/luci/menu.d

+ 0 - 13
luci-app-olsrd2/root/etc/uci-defaults/41_luci-olsrd2

@@ -1,13 +0,0 @@
-#!/bin/sh
-
-uci -q batch <<-EOF >/dev/null
-	delete ucitrack.@olsrd2[-1]
-	add ucitrack olsrd2
-	set ucitrack.@olsrd2[-1].init=olsrd2
-	commit ucitrack
-EOF
-
-rm -f /tmp/luci-indexcache
-rm -f /tmp/luci-modulecache/*
-
-exit 0

+ 4 - 0
luci-app-olsrd2/root/usr/share/ucitrack/luci-app-olsrd2.json

@@ -0,0 +1,4 @@
+{
+	"config": "olsrd2",
+	"init": "olsrd2"
+}